... the user friendly GPS tool

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Waypoint numbering
(22.07.2015, 20:27)Stav Wrote: Anybody else had similar issue?

Yes, from time to time people report exactly the same report. Since it is reproducible, please take your time and try the latest prerelease which I've just uploaded. It tries to avoid the crash. But I cannot test it.
Tried latest release 2.16 -493. It loads but without a map.
Please try the 2.16-SNAPSHOT -491 from today. It uses a different way to initialize the map
2.16-SNAPSHOT -491 loaded OK but crashed after .

Loading GPX file > Position > Complete > (selected all positions) Populated Places

Then ...

Position > Complete > (selected all positions) Number or Postal etc.. == Crashed when clicked on one position on list

Same result on both choices of OPTIONS > EXTRAS ( Position List or Current Selection )

I noticed it happens after the action " Position > Complete > xxx " is performed for the second time

# A fatal error has been detected by the Java Runtime Environment:
# EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x57f80cc2, pid=4044, tid=8060
# JRE version: Java™ SE Runtime Environment (8.0_51-b16) (build 1.8.0_51-b16)
# Java VM: Java HotSpot™ Client VM (25.51-b03 mixed mode windows-x86 )
# Problematic frame:
# C [jfxwebkit.dll+0xa10cc2]
# Failed to write core dump. Minidumps are not enabled by default on client versions of Windows
# If you would like to submit a bug report, please visit:
# http://bugreport.java.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.

--------------- T H R E A D ---------------

Current thread (0x48e3a000): JavaThread "JavaFX Application Thread" [_thread_in_native, id=8060, stack(0x489f0000,0x48a40000)]

siginfo: ExceptionCode=0xc0000005, writing address 0xbbadbeef

EAX=0x00000000, EBX=0x00027000, ECX=0x7704539
Hi Christian
Have you had time to look at that
(05.08.2015, 10:59)Stav Wrote: Have you had time to look at that

Hi Stav,

there is nothing to look at since I cannot reproduce the problem, it's an Oracle problem, and have no idea how to work around it.
So I'm collecting data. You have the same problem that a few other users have - the Java VM crashes.

Two users reported interesting observations:
  • Removing and reinstalling the Nvidia grafic drivers solved the crashes for one user.
  • Deinstalling the 32-bit Java on a 64-bit Windows and installing a 64-bit Java solved the crashes for a second user.
So does updating the grafic drivers and/or deinstalling the 32-bit Java help on your machine?
2.16-SNAPSHOT -518

Hi Christian,

Removed Nvidia and re-installed latest version. It seems to be working fine - I say "seems" as it crashed once when testing it by playing around with "Complete..." with various combinations.

It crashed once within 20+ changes so we could put it down to finger problem.

Keep fingers crossed that is resolved - I will let you know how it performs but one thing for sure now my waypoints are in sync with Mapfactor announcements and many thanks for that ( BTW my thanks to @hvdwolf as well for helping me extending the Mapfactor waypoint numbering).


Forum Jump:

Users browsing this thread: 1 Guest(s)