... the user friendly GPS tool


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
RC 2.1 unter Ubuntu 10.10: keine Wegpunkte in Karte
#21
(21.02.2011, 19:22)routeconverter Wrote: Bitte probiert mal die neueste Vorabversion von http://www.routeconverter.de/prereleases/ aus, die versucht unter Linux erst die Karte mit WebKit als Browser zu starten und falls das scheitert mit XULRunner. Das funktioniert bei meinem Ubuntu 10.04 gut. Und bei Euch?
axel.rehling Wrote:der Workarount, sowie das Prerelease, funktionieren bei mir ohne erkennbare Probleme!

Hallo Christian,

bin z.Z. viel auf Achse und konnte deshalb erst jetzt testen.
In allen Varianten bekomme ich die Fehlermeldung siehe Anhang Sad.

Vielleicht ist bei mir auch das Webkit nicht vollständig. Installiert ist:
- libwebkit-1.0-2
- libwebkit-1.0-common

Da gibt's jedoch noch viel mehr - keine Ahnung was ich da brauche.

Jedenfalls öffnet er das Fenster - jedoch ohne Karte - und hängt dann. Fenster lässt sich nicht mal mehr schließen - nur mit Gewalt.

axel.rehling Wrote:Ich habe zwei PC mit dem selben BS (LinuxMint 9; 1x32bit, 1x64bit; Ubuntu 10.04-Derivat), beim 64bit-PC habe ich diese Anzeigeprobleme nicht und beim 32bit-PC habe ich sie.

Interessant ist, dass Axel mit 64bit Ubuntu die Anzeigeprobleme von vornherein nicht hat, ich jedoch habe sie.

Danke für deine Mühe und viele Grüße!
Thomas


Attached Files
.txt   errormessage.txt (Size: 1.04 KB / Downloads: 802)
.txt   hs_err_pid4802.txt (Size: 65.87 KB / Downloads: 875)
Reply
#22
Hallo all den Helfern und vielen Dank!

HURRAAAA - es läuft !!Big Grin

Sowohl unter dem Terminal-Aufruf als auch die Vorabversion.

Dann spar' ich mir mal die wine-Version - war eh nur ein Versuch.

@axel: Danke für Deine hilfreichen Hinweise; bin im Linux-Umfeld noch Anfänger und arbeite mich gesundheits- und berufsbedingt nach rund 15 Jahren Pause wieder ins EDV-Umfeld ein - sorry bitte dafür wenn ich Dinge von mir gebe, die für Experten nicht nachvollziehbar sind; gib mir eine Nixdorf 8870/6 und ich schreibe Dir den Assembler dafür Cool

Noch nen schönen Abend an Alle!

Schöne Grüße
-volker-

Reply
#23
(22.02.2011, 22:00)lintho60 Wrote: Da gibt's jedoch noch viel mehr - keine Ahnung was ich da brauche.

Ich habe da nichts besonderes für installiert. Nur ein Ubuntu 10.04 in der Desktop-Variante.

(22.02.2011, 22:00)lintho60 Wrote: Jedenfalls öffnet er das Fenster - jedoch ohne Karte - und hängt dann. Fenster lässt sich nicht mal mehr schließen - nur mit Gewalt.

Das hs_err_pid4802.txt läßt auf einen Absturz der JavaVM beim Initialisieren eines WebKit-basierten Browsers schließen:

Quote:Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
j org.eclipse.swt.internal.webkit.WebKitGTK._soup_session_get_feature(JI)J+0
j org.eclipse.swt.internal.webkit.WebKitGTK.soup_session_get_feature(JI)J+9
j org.eclipse.swt.browser.WebKit.create(Lorg/eclipse/swt/widgets/Composite;I)Z+887
j org.eclipse.swt.browser.Browser.<init>(Lorg/eclipse/swt/widgets/Composite;I)V+302
j chrriis.dj.nativeswing.swtimpl.components.core.NativeWebBrowser.createControl(Lorg/eclipse/swt/widgets/Composite;[Ljava/lang/ObjectWinkLorg/eclipse/swt/widgets/Control;+100

(22.02.2011, 22:00)lintho60 Wrote: Interessant ist, dass Axel mit 64bit Ubuntu die Anzeigeprobleme von vornherein nicht hat, ich jedoch habe sie.

Du hast die 64-bit RouteConverter-Variante heruntergeladen, oder?

Hast Du mal die Sun JavaVM ausprobiert?
--
Christian
Reply
#24
(22.02.2011, 22:11)voschi Wrote: HURRAAAA - es läuft !!Big Grin

Klasse.


D.h. bislang sieht es so aus:

- Ubuntu 10.04 32-bit läuft bei mir
- Ubuntu 10.10 unbekannte-bits läuft bei Volker
- Ubuntu 10.10 64-bit 1.6._20 OpenJDK crasht bei Thomas
- LinuxMint 9, Ubuntu 10.04-Derivat, bei 64-bit lief es stets, bei 32-bit erst mit WebKit

Ich erkenne da kein Muster. Könntet ihr kurz die Daten vervollständigen? Also nach dem Schema:

OS + OS-Version, 32/64-bit, Sun/OpenJDK, JDK-Version, läuft/crasht wann
--
Christian
Reply
#25
Hallo,
hier meine "Umgebung":

Ubuntu 10.10, Linux-Kernel 2.6.35, 32bit, sun-java6-(bin jre jdk plugin) jedes in der Version 6.24-1build0.10.10.1, RC 2.2 v. 18.1.11 läut nur mittels Webkit, RC 2.3 (Prerelease v. 21.2.11) läuft mit normalem Aufruf.

Reichen diese Angaben?

Schönen Abend!
-volker-
Reply
#26
(23.02.2011, 00:13)voschi Wrote: Reichen diese Angaben?

Ja. Danke!
--
Christian
Reply
#27
Hallo Christian,

hier auf die Schnelle erst mal die Antwort auf deine Fragen:

Christian Wrote:Du hast die 64-bit RouteConverter-Variante heruntergeladen, oder?
Ja, RouteConverterPrereleaseLinux64.jar!
Christian Wrote:Hast Du mal die Sun JavaVM ausprobiert?
Nein - bis jetzt noch nicht. Werde ich noch probieren, muss mich aber erst mal schlau machen ob man mehrere Javas parallel installieren kann und wenn ja, wie man steuert welche Java verwendet wird. Bin leider nicht so der Systemfreak und habe etwas Angst davor mein gut funktionierendes System zu zerschießen.
Christian Wrote:OS + OS-Version, 32/64-bit, Sun/OpenJDK, JDK-Version, läuft/crasht wann
OS: Ubuntu 10.10; Kernel 2.6.35-25-generic; 64bit
Java: java version "1.6.0_20"
OpenJDK Runtime Environment (IcedTea6 1.9.5) (6b20-1.9.5-0ubuntu1)
OpenJDK 64-Bit Server VM (build 19.0-b09, mixed mode)
RC 2.2 ohne Webkit läuft, zeigt aber keine Wegpunkte
RC 2.2 mit Webkit crasht
RC 2.3 normaler Aufruf crasht genau wie 2.2 mit Webkit

Wenn ich es morgen schaffe, teste ich SunJava. Melde mich dann wieder.

Gruß!
Thomas


Reply
#28
Hallo zusammen,

habe es nun geschafft Sun-Java zu installieren - so dass ich wechseln kann - und ein wenig zu testen.

RC 2.2 ohne Webkit:
Wie üblich - läuft aber keine Wegpunkte

RC 2.2 mit Webkit:
Im Normalfall (ca. 9 von 10 mal) crasht es, siehe Anhang. Aber - ihr werdet mich für bekloppt halten - ab und zu (ca. 1 von 10 mal) funktioniert's und zwar mit beiden Java Versionen. Wenn es mal klappt, werden Wegpunkte Route u.s.w. korrekt dargestellt.

RC 2.3:
Crasht.

Ich versteh's nicht, aber irgendwie sieht das nach einem Timing-Problem aus - kann das sein?

Gruß!
Thomas

.txt   error_Sun_OpenJDK.txt (Size: 2.04 KB / Downloads: 915)
Reply
#29
(27.02.2011, 20:28)lintho60 Wrote: Ich versteh's nicht, aber irgendwie sieht das nach einem Timing-Problem aus - kann das sein?

Ja, das könnte sein. Die JVM-Crashes deuten darauf hin, daß die Eclipse SWT 3.6-Binaries nicht zum WebKit 1.0.2 auf Deinem Rechner passen. Es gibt inzwischen Eclipse SWT 3.6.1 und hier habe ich gesehen, daß WebKit 1.2.0 laufen soll. Zwei weitere Optionen... magst Du das WebKit aktualisieren?
--
Christian
Reply
#30
(27.02.2011, 20:34)routeconverter Wrote: Ja, das könnte sein. Die JVM-Crashes deuten darauf hin, daß die Eclipse SWT 3.6-Binaries nicht zum WebKit 1.0.2 auf Deinem Rechner passen. Es gibt inzwischen Eclipse SWT 3.6.1 und hier habe ich gesehen, daß WebKit 1.2.0 laufen soll. Zwei weitere Optionen... magst Du das WebKit aktualisieren?

Mögen schon - aber ich blicke da noch nicht durch!

Soweit ich feststellen kann ist gar kein Eclipse installiert. Auch die Suche nach SWT in meiner Paketverwaltung gab kein Ergebnis.

Meine installierte Version von Webkit ist:
libwebkit-1.0-2 Version: 1.2.5-0ubuntu0.10.10.1
Meine Paketverwaltung sagt mir, dass dies die neueste verfügbare Version sei.

Wenn Du von Webkit 1.2.0 sprichst, meinst du dann
libwebkit-1.2-0 Version: xxx
oder
libwebkit-1.0-2 Version: 1.2.0


Die Suche im Internet hat mich auf die Schnelle auch noch nicht weitergebracht.

Welche Version libwebkit-xx Version: yy hast denn Du auf deinem Ubuntu 10.04??

Grüße und Danke für deine Hilfe!
Thomas

Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)